Autor Thema: IDE/SATA DVD-Laufwerke werden nicht erkannt  (Gelesen 4036 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Vitali

  • Jr. Member
  • *
  • Beiträge: 67
  • Bewertung der Beiträge: 0
  • Geschlecht: Männlich
    • Profil anzeigen
IDE/SATA DVD-Laufwerke werden nicht erkannt
« am: Dezember 14, 2014, 00:32:52 »
Wie es in der Überschrift schon steht, hab ich an einem älteren PC nach einer Umstellung von IDE HDD auf SATA HDD/SSD ein Problem mit der Erkennung der Laufwerke.

System:

Medion Pc MT6 MED MT 312
- Pentium 4 3.40 GHz
- 2.560 MB DDR-RAM
- MSI 7091 Vers. 1.0 Board mit 1 IDE und 4x SATA
- vorher eine 200 GB HDD (IDE)
- jetzt 300GB HDD (SATA) und 64GB SSD (SATA)
- 1x DVD Player (IDE)
- 1x DVD Brenner (IDE)
- zum testen DVD-Player (SATA)
- etc.

Die ursprüngliche Konfiguration (HDD mit zwei DVD-Laufwerken) lief über den IDE Port ohne Probleme. Seit der Änderung auf eine SATA Platte wird nur noch eine SATA Platte erkannt. Weitere Laufwerke sind angeschlossen aber werden nicht angezeigt.

Ich weiß nicht ob ich was in der BIOS Einstellung falsch mache, hab aber schon alle möglichen Varianten durchprobiert.  :x

Die aktuelle Einstellung: (Ein kurzer Auszug aus dem Bios)

IDE Devices Configuration
- PCI IDE BusMaster = Enabled
- On-Chip Primary PCI IDE = Enabled

SATA Devices Configuration
- SATA Mode = IDE
- On-Chip Serial ATA = Combined Mode
- PATA IDE Mode = Secondary
- SATA Port = SATA1 is Primary (hier keine Auswahlmöglichkeit)

Bei dieser Einstellung wird von der SSD-Festplatte unter SATA-Port 1,2,3 oder 4 gebootet (Windows 7 Ultimate 32bit). Weitere Festplatten (SATA) oder DVD Laufwerke (SATA/IDE) werden im Bios und im Windows nicht erkannt.
Das seltsame ist, wenn statt einer HDD ein DVD Laufwerk angeschlossen wird und mit einer LIVE CD bootet, werden trotzdem keine Laufwerke erkannt (außer das Bootlaufwerk).

Diese Einstellungen können ausgewählt werden:

SATA Devices Configuration
- SATA Mode = IDE / RAID / AHCI
- On-Chip Serial ATA = Disabled / AUTO / Combined Mode / Enhanced Mode / SATA only
- PATA IDE Mode = Primary / Secondary
- SATA Port = SATA1 is Primary / SATA2 is Secondary (hier keine Auswahlmöglichkeit, wird automatisch umgestellt je nach dem was unter PATA ausgewählt wurde)

Einstellungen ausprobiert:

SATA Devices Configuration
- SATA Mode = AHCI / RAID
- On-Chip Serial ATA = Enhanced Mode (hier keine Auswahlmöglichkeit)
- PATA IDE Mode = Primary (hier keine Auswahlmöglichkeit)
- SATA Port = SATA2 is Secondary (hier keine Auswahlmöglichkeit)

weitere Einstellungen ausprobiert:

SATA Devices Configuration
- SATA Mode = IDE
- On-Chip Serial ATA = Disabled / AUTO / Enhanced Mode / SATA only
- PATA IDE Mode = Primary (hier keine Auswahlmöglichkeit)
- SATA Port = SATA2 is Secondary (hier keine Auswahlmöglichkeit)


Hierbei werden ALLE Laufwerke im Bios erkannt. Beim starten erscheint das Pentium 4 Logo, dann folgt kurz der BIOS-Post und dann wird der Bildschirm schwarz (hier sollte eigentlich das Betriebssystem geladen werden) und es kommt zu einem Neustart mit dem Pentium 4 Logo und geht als Endlosschleife weiter.

Kann es sein, dass die Kombination SATA und IDE vor +/- 10 Jahren nicht möglich war???

(Falls hier angekommen, danke für die Geduld beim lesen  :-D )

LG Vitali

Offline Baldrian

  • Global Moderator
  • Hero Member
  • *****
  • Beiträge: 2433
  • Bewertung der Beiträge: 28
  • Geschlecht: Männlich
    • Profil anzeigen
    • ecarux.de
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #1 am: Dezember 15, 2014, 19:58:32 »
Also erst mal ne Frage:
Wie hast du denn 1x IDE HDD, 1x IDE DVD (Player) und 1x IDE DVD (Brenner) angeschlossen?
Das Board hat doch nur einen IDE (PATA) Port - Also können es doch max 2 Geräte gewesen sein.

Zu beachten ist auch, wo du was anschließt.
Die Festplatte zum booten muss bei deinem Board am SATA Port 1 o. 2 angeschlossen sein.
Ich schätze mal es ist bei dir die SSD. Also hängst du die SSD am besten gleich an Port 1.

Für die SSD solltest du den SATA mode unbedingt auf AHCI stellen.
Ansonsten wir TRIM nicht funktionieren und du wirst mit deiner SSD nicht viel Spaß auf Dauer haben.

Beachte auch, dass du an dieser Stelle nicht die Bootreihen folge änderst.
Dafür gibt es in der Regel eine anderen Menüpunkt im BIOS.
Wenn dein Rechner also nicht bootet, hast du vielleicht die SSD auch nicht als Bootdevice ausgewählt.

Außerdem werden  für die verschiedenen Modi auch verschiedene Treiber benötigt.
Ohne Eingriff in die Registry wird ein im IDE Modus installiertes Windows nicht mehr booten wenn du den Controller auf AHCI umstellst.



"Was auch immer geschieht, nie dürft ihr so tief sinken,
von dem Kakao, durch den man euch zieht, auch noch zu trinken."

Offline Vitali

  • Jr. Member
  • *
  • Beiträge: 67
  • Bewertung der Beiträge: 0
  • Geschlecht: Männlich
    • Profil anzeigen
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #2 am: Dezember 16, 2014, 00:07:20 »
Hi Baldrian, erstmal Danke für deine Hilfe!
Mir kommt es so vor, dass nur DU und vielleicht noch 3 - 4 andere hier AKTIV helfen bzw. sich um die Anfragen oder Probleme kümmern. Das finde ich echt SUPER, vielen Dank!!!!

--------------------------------------------------------------------------------------------------------------
Also erst mal ne Frage:
Wie hast du denn 1x IDE HDD, 1x IDE DVD (Player) und 1x IDE DVD (Brenner) angeschlossen?
Das Board hat doch nur einen IDE (PATA) Port - Also können es doch max 2 Geräte gewesen sein.

Ich hab den Rechner vor ein paar Jahren kostenlos von einem Arbeitskollegen bekommen. Es war zuletzt nur eine IDE HDD und ein IDE DVD-Laufwerk angeschlossen. Ich vermute es, dass es noch vom Vorbesitzer geändert wurde. Auf dem Gehäuse befindet sich zwar ein XP-Lizenz Aufkleber, aber es war Vista drauf. Wahrscheinlich lief der Rechner mal mit einer SATA Platte und zwei IDE-Laufwerken.
-----------------------------------------------------------------------------------------------------------------
Zu beachten ist auch, wo du was anschließt.
Die Festplatte zum booten muss bei deinem Board am SATA Port 1 o. 2 angeschlossen sein.
Ich schätze mal es ist bei dir die SSD. Also hängst du die SSD am besten gleich an Port 1.

Die SSD Festplatte ist an SATA 1 angeschlossen, wurde aber auch schon SATA 2 Port getestet. Ansonsten hängen nur noch die beiden DVD-Laufwerke (Jumper auf Master / Slave sind berücksichtigt) an IDE.
-------------------------------------------------------------------------------------------------------------------
Für die SSD solltest du den SATA mode unbedingt auf AHCI stellen.
Ansonsten wir TRIM nicht funktionieren und du wirst mit deiner SSD nicht viel Spaß auf Dauer haben.

Das mit der TRIM-Funktion ist mir bekannt (Lebensdauer, Leistung etc.). Allerdings hab ich dann das Problem (AHCI), dass sich der Rechner in dieser Endlosschleife verfängt.
SATA Devices Configuration
- SATA Mode = AHCI / RAID
- On-Chip Serial ATA = Enhanced Mode (hier keine Auswahlmöglichkeit)
- PATA IDE Mode = Primary (hier keine Auswahlmöglichkeit)
- SATA Port = SATA2 is Secondary (hier keine Auswahlmöglichkeit)

Es kommt noch nicht mal das " Windows wird gestartet ".

Das selbe passiert aber auch bei der IDE Einstellung:

SATA Devices Configuration
- SATA Mode = IDE
- On-Chip Serial ATA = Disabled / AUTO / Enhanced Mode / SATA only (hier ist es egal was ich auswähle!!!)
- PATA IDE Mode = Primary (hier keine Auswahlmöglichkeit)
- SATA Port = SATA2 is Secondary (hier keine Auswahlmöglichkeit)
----------------------------------------------------------------------------------------------------------------------
Beachte auch, dass du an dieser Stelle nicht die Bootreihen folge änderst.
Dafür gibt es in der Regel eine anderen Menüpunkt im BIOS.
Wenn dein Rechner also nicht bootet, hast du vielleicht die SSD auch nicht als Bootdevice ausgewählt.

Das ist unter Boot Device Priority zu finden. Dort wird die SSD oder HDD erkannt, ansonsten ist die Reihenfolge: DVD, Festplatte, andere Geräte. Auch hier schon alles durchprobiert.
-----------------------------------------------------------------------------------------------------------------------
Außerdem werden  für die verschiedenen Modi auch verschiedene Treiber benötigt.
Ohne Eingriff in die Registry wird ein im IDE Modus installiertes Windows nicht mehr booten wenn du den Controller auf AHCI umstellst.

Was ich nicht verstehe ist, wieso kommt noch nicht mal das Windows LOGO. Der Rechner startet nach dem POST immer wieder neu!
Nachträgliches Ändern von IDE auf AHCI Modus (Windows) ist manuell ohne große Probleme möglich.

Das ist die einzige Einstellung wo sich der Rechner mit dem Betriebssystem starten lässt (egal ob SSD oder HDD). Aber dann ohne die DVD Laufwerk(e) zu erkennen.

SATA Devices Configuration
- SATA Mode = IDE
- On-Chip Serial ATA = Combined Mode
- PATA IDE Mode = Secondary
- SATA Port = SATA1 is Primary (hier keine Auswahlmöglichkeit)

Wenn ich unter PATA IDE Mode = Primary auswähle, steht bitte Boot Medium einlegen (nur auf Englisch).
Der SATA Port steht dann auf SATA2 is Secondary. Hier ist es aber auch egal ob die SSD/HDD auf SATA Port 1 oder 2 angeschlossen ist. Die Boot Medium Meldung kommt immer.

Kann es sein dass eventuell was mit den Ports nicht stimmt???

Offline michael0606

  • Newbie
  • *
  • Beiträge: 30
  • Bewertung der Beiträge: 0
  • Geschlecht: Männlich
    • Profil anzeigen
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #3 am: Dezember 16, 2014, 07:40:20 »
Wenn es möglich ist dann versuchen das BIOS zu aktualisieren.
Die Jumper der IDE mal nur auf Slave geben.
Hast du Windows installiert und danach auf AHCI umgestellt?dann mußt du etwas in der Registri umstellen...

Versuche auch mal Probehalber ohne DVD-Laufwerke zu booten bzw. einzeln jeweils das eine Laufwerk..

Kannst du versuchen im Abgesicherten Modus zu kommen/starten?Wenn ja dann ist es der Ahci oder eben ein Treiberproblem.

MfG Mike

Offline Vitali

  • Jr. Member
  • *
  • Beiträge: 67
  • Bewertung der Beiträge: 0
  • Geschlecht: Männlich
    • Profil anzeigen
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #4 am: Dezember 16, 2014, 16:16:25 »
Hallo Michael 0606,
---------------------------------------------------------------------------------------------------------------------------------

Wenn es möglich ist dann versuchen das BIOS zu aktualisieren.
Die Jumper der IDE mal nur auf Slave geben.
Hast du Windows installiert und danach auf AHCI umgestellt?dann mußt du etwas in der Registri umstellen...


Die Jumper hab ich schon hin und her probiert, brachte leider kein Ergebnis.
Die Installation erfolgte erst auf der SATA HDD im IDE Modus (nach späterer Entscheidung wurde die Platte HDD auf SSD mit Clonezilla auf einem anderen Rechner geklont). Es ist aber egal ob ich die HDD oder SSD dran hänge, das Problem bleibt trotzdem. Ich verstehe aber auch nicht woran es liegt, bei der Installation wurde doch vom DVD Laufwerk gebootet.  :|
Nach einer neuen Version vom BIOS hab ich noch nicht geschaut.
----------------------------------------------------------------------------------------------------------------------------------
Versuche auch mal Probehalber ohne DVD-Laufwerke zu booten bzw. einzeln jeweils das eine Laufwerk.

Mit der einen BIOS Einstellung bootet der Rechner ja, es werden aber keine IDE Laufwerke angezeigt.
----------------------------------------------------------------------------------------------------------------------------------
Kannst du versuchen im Abgesicherten Modus zu kommen/starten?Wenn ja dann ist es der Ahci oder eben ein Treiberproblem.

Im Abgesicherten Modus werden auch keine Laufwerke erkannt, noch nicht einmal im BIOS.
-----------------------------------------------------------------------------------------------------------------------------------

Es bleibt noch ein Versuch mit dem BIOS Update!

LG Vitali


Offline michael0606

  • Newbie
  • *
  • Beiträge: 30
  • Bewertung der Beiträge: 0
  • Geschlecht: Männlich
    • Profil anzeigen
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #5 am: Dezember 16, 2014, 20:50:32 »
Kannst du ein Video machen oder Fotos raufladen vom BIOS bzw. Bootvorgang?

Hast du es öfters neuinstalliert das Windows?Stell mal den SATA auf AHCI. PATA auf Secondery.On Chip Serial auf SATA only (Wenn du alles über SATA angeschlossen hast) ansonst auf Auto.
Wenn du Win startest und es nicht funktioniert dann versuche es mit einer Neuinstallation aber die Treiber sichern.(oder eine Linux Live Distri über DVD oder USB).

MfG Mike

Offline Vitali

  • Jr. Member
  • *
  • Beiträge: 67
  • Bewertung der Beiträge: 0
  • Geschlecht: Männlich
    • Profil anzeigen
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #6 am: Dezember 17, 2014, 00:23:01 »
Hey Mike,

dein Hinweis mit dem BIOS Update war ein Volltreffer!

Bei dem alten BIOS (Version 3.06 28.10.2004) war unter AHCI die Auswahl PATA Secondary nicht möglich (grau hinterlegt).
Update von Medion Webseite auf die Version 3.15 24.06.2010 brachte die Lösung und auch die Freischaltung der diversen Kombinationsmöglichkeiten unter IDE AHCI SATA etc.

Vielen Dank an ALLE!

LG Vitali

Offline michael0606

  • Newbie
  • *
  • Beiträge: 30
  • Bewertung der Beiträge: 0
  • Geschlecht: Männlich
    • Profil anzeigen
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #7 am: Dezember 17, 2014, 07:22:28 »
Na sehr gut.Bitte sehr.

 :-D

Immer schön wenn etwas funktioniert.

Offline Baldrian

  • Global Moderator
  • Hero Member
  • *****
  • Beiträge: 2433
  • Bewertung der Beiträge: 28
  • Geschlecht: Männlich
    • Profil anzeigen
    • ecarux.de
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #8 am: Dezember 18, 2014, 23:08:21 »
Freut mich, dass es geklappt hat.
"Was auch immer geschieht, nie dürft ihr so tief sinken,
von dem Kakao, durch den man euch zieht, auch noch zu trinken."

Offline Vitali

  • Jr. Member
  • *
  • Beiträge: 67
  • Bewertung der Beiträge: 0
  • Geschlecht: Männlich
    • Profil anzeigen
Re: IDE/SATA DVD-Laufwerke werden nicht erkannt
« Antwort #9 am: Dezember 19, 2014, 00:59:30 »
Mich hat es auch sehr gefreut!

GANZ GROßES LOB AN EUCH BEIDE und VIELEN DANK!

Vitali